WHMCS Update


Attention Resellers, A message from WHMCS!

WHMCS has released new patches for the 5.2.7 minor releases. These updates provide targeted changes to address security concerns with the WHMCS product. You are highly encouraged to update immediately.

WHMCS has rated these updates as having a critical security impacts. Information on security ratings is available at – http://docs.whmcs.com/Security_Levels.

Releases

The following patch release versions of WHMCS have been published to address a specific SQL Injection vulnerability: v5.2.8

Security Issue Information

The resolved security issue was publicly disclosed by “localhost” on October 3rd, 2013.
The vulnerability allows an attacker, who has valid login to the installed product, to craft a SQL Injection Attack via a specific URL query parameter against any product page that updates database information.

Mitigation

WHMCS Version 5.2.7

Download and apply the appropriate patch files to protect against these vulnerabilities.

Patch files for affected versions of the 5.2.7 series are located on the WHMCS site as itemized below.

v5.2.8 (full version) – Downloadable from the e2 Brain Client Area
v5.2.8 (patch only; for 5.2.7) – http://go.whmcs.com/218/v528_Incremental

Th apply a patch, download the files indicated above and replace the files within your installation.
No upgrade process is required.

Leave a Reply

Your email address will not be published. Required fields are marked *